public void move(int boost)
{
    if(isVisible)
    {
        y += boost;
    }
}
testing for a boolean instead of its opposite is generally clearer code, and this doesn't require an extra return statement.